首頁 [教學]解決P3更新至4.60版後出現的認證問題
« 首頁 »
2011 年 07 月 01 日 留言:0

[教學]解決P3更新至4.60版後出現的認證問題

Plurk
分享文章

(不知道什麼是P3的人,可參考這裡的文章。)

距離上一版P3更新也有一段時間了……這次更新一口氣從4.44跳到4.60,其中到底發生了什麼事呢?大概是不可說的祕密吧(並不是)

總之這一版本更新之後最明顯的不同,就是更新後打開程式時會跳出一個要你認證的視窗。這個東西主要就是twitter的Oauth認証(也就是所謂的開放授權)意思就是允許P3修改或是更新twitter上的資料。

基本上這認證很簡單,我想應該不用特別說明也能完成。(當初作者還請我翻譯了認證過程中會出現的說明文字,我想應該不至於看不懂……)但有個問題來了,似乎只要是把P3資料夾裡的+Properties資料夾的「+」拿掉,讓設定檔可以保存在裡面的人,在認證時都會出現錯誤訊息。

雖然經過我的測試,就算有錯誤還是能更新訊息,而且作者事後好像也更新程式了,現在或許不會再有這種現象,但為了保險起見,還是告訴大家如何輕鬆解決這個問題吧!

把P3資料夾裡的+Properties資料夾的「+」拿掉,讓設定檔可以保存在裡面的人,認證時填好pin碼後可能會出現以下畫面:

這時候該如何解決呢?

首先請先找到你放P3主程式的資料夾。打開之後找到「Properties」這個子資料夾,在裡面新增一個叫做「Account」的空資料夾(裡面請不要放任何檔案,也不要移動到其他檔案)。

然後……就大功告成了!!

 

沒錯!就是這麼簡單啦!接下來再重新開啟P3主程式,重新進行認證,應該就不會再有錯誤訊息囉!

 

(以上教學感謝作者Lynmock先生的提供。相關說明請看這裡。)

發表迴響